Scientific colour maps” v.cue

Version 7.0.0

v Perceptually uniform

v Perceptually ordered

v Colour-vision-deficiency (CVD) friendly
v Readable as black and white print

v Provided in all major formats

v Citable & reproducible

Crameri, F. (2018), Scientific colour maps, Zenodo, doi:10.5281/
zenodo.1243862

Crameri, F. (2018), Geodynamic diagnostics, scientific visual-
isation and Staglab 3.0, Geosci. Model Dev., 11, 2541-2562,
doi10.5194/gmd-11-2541-2018

Crameri, F., G.E. Shephard, and P.J. Heron (2020), The misuse
of colour in science communication, Nature Communications, 11,
5444. doi: 10.1038/s41467-020-19160-7
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1 Creators & sources of inspiration

Creator: Fabio Crameri

Contributors: Grace Shephard - Conversion to .cpt format, promotion of Sci-
entific colour maps, and other contributions

Phil Heron - Promotion of Scientific colour maps

Clint Conrad - Wider compatibility of .cpt format

Matteo Albano - Conversion to .clr format; QGIS compatibility
Casper Pranger - Mathematica compatibility

Alexis Plunder - Wider compatibility of .xml format

Krister Stroete Karlsen - User instruction for use with python
Philippe Riviere - Conversion instruction for d3

Emilia - Plotly versions

Thomas Lin Pedersen - The ‘scico’ package for use with R
Paul Wessel - Built-in version for ‘GMT’

Wolfgang Schwanghart - Built-in version for ‘TopoToolbox’
Chad Greene - MatLab file exchange version

Sean Trim - Conversion to .pal format

George Edward Campbell - Conversion to .lut format
Christophe Leterrier - NeuroCyto LUTs Fiji add-on

Kirstie Wright - User instruction for use with Petrel

Craig Williams - Style file for ArcGIS Pro

Jennifer Levett - Conversion to SKUA-GOCAD .xcmap format
Sam Hatfield - Conversion to Ncview .ncmap format

Patrick Brockmann - Conversion to Ferret .spk format
Thomas Morrow - Conversion to QPS .cmap format

Mark Wieczorek - Import init file for Python

Anthony Jamelot - Additions to import init file for Python
Andy Emery - Conversion to Kingdom .clm and .clb format
Benjamin Witschas - Conversion to Originlab .pal format
Steven Reddy - Conversion to Photoshop .grd format

Callum Rollo - Python package via pip and anaconda

Pierre Lanari - Built-in version for ‘XMapTools’

Kaspar Merz - Importable package for ‘OpendTect’
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https://www.fabiocrameri.ch/contact.php
http://www.mn.uio.no/geo/english/people/aca/ceed/gracees/
https://philheron.com
http://www.mn.uio.no/geo/english/people/aca/ceed/clinton/
https://twitter.com/matteo_albano?lang=en
https://www.erdw.ethz.ch/en/people/profile.html?persid=205634
https://sites.google.com/site/alexisplunder
http://www.mn.uio.no/geo/english/people/aca/ceed/krikarls/
https://twitter.com/recifs?lang=en
https://twitter.com/mathinpython?lang=en
https://twitter.com/thomasp85?lang=en
http://www.soest.hawaii.edu/GG/people/gg_profile_wessel_p.html
https://twitter.com/wschwanghart?lang=en
http://www.chadagreene.com
http://www.seantrim.com
https://twitter.com/geobellward
https://twitter.com/christlet
http://www.rocksandwiggles.com
https://twitter.com/williamscraigm
http://www.mirageoscience.com
https://samhatfield.co.uk/
https://github.com/PBrockmann
https://twitter.com/thethomasmorrow
http://www.oca.eu/fr/mark-wieczorek
mailto:jamelot@labogeo.pf
https://twitter.com/AndyDoggerBank
https://www.dlr.de/pa/desktopdefault.aspx/tabid-2357/3477_read-19538/sortby-lastname/
http://www.geoscienceatomprobe.org/contact.html
https://github.com/callumrollo
http://pierre-lanari.com
https://www.linkedin.com/in/kasparmerz/?originalSubdomain=ch

Sources of inspiration:
The ‘endrainbow’ campagn initiated by Ed Hawkins.

The Colorbrewer colour maps, the MPL colour maps, the cividis
colour map, the CMOcean colour maps, and the CET colour
maps.

Peter Kovesi's work, in particular, has helped to develop the Sci-
entific colour maps: some of the many excellent, openly acces-
sible scripts were used as a basis for the applied colour-map
diagnostics and to make the file conversion to .tbl and .act for-
mats.

2 Acknowledgement

I — Please acknowledge the free use of the colour maps.

e.qg., "The Scientific colour map batlow (Crameri 2018) is used in
this study to prevent visual distortion of the data and exclusion of
readers with colour-vision deficiencies (Crameri et al., 2020).”

The software : Crameri, F. (2018a), Scientific colour maps. Zenodo. http:/
doi.org/10.5281/zen0do.1243862

The research : Crameri, F.,, G.E. Shephard, and P.J. Heron (2020), The mis-
use of colour in science communication, Nature Communi-
cations, 11,5444, doi: 10.1038/s41467-020-19160-7
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http://www.climate-lab-book.ac.uk/2014/end-of-the-rainbow/
http://colorbrewer2.org
https://bids.github.io/colormap/
https://doi.org/10.1371/journal.pone.0199239.s002
https://doi.org/10.1371/journal.pone.0199239.s002
https://matplotlib.org/cmocean/
https://peterkovesi.com/projects/colourmaps/
https://peterkovesi.com/projects/colourmaps/
https://www.peterkovesi.com
https://www.peterkovesi.com/matlabfns/index.html#colour
https://www.peterkovesi.com/matlabfns/index.html#colour
http://doi.org/10.5281/zenodo.1243862
http://doi.org/10.5281/zenodo.1243862
https://doi.org/10.1038/s41467-020-19160-7

3 Instructions
31 ArcGIS Pro
3.1.1 style file

Download the style file for the ArcGIS Pro provided by Craig
Williams on https://www.arcgis.com/home/.

3.2 COMSOL Multiphysics
3.2.1 txt format

Put the .txt colour map files in COMSOL4.0a > data > colortables
(adjust version number, if necessary) Then restart COMSOL and
the Scientific colour maps should be available within the pro-
gram.

3.3 d3
3.31 xml format

An instruction to convert the .xml format to d3’s internal repre-
sentationis provided by Philippe Riviere at https://beta.observablehg
.com/@fil/colormaps.

3.4 Ferret
3.4.1 .spk format

To use the .spk colour map files in Ferret, follow the instructions
given on the officialhomepage: https://ferret.omel.noaa.gov/Ferret/
documentation/users-guide/customizing-plots/COLOR#_VPID_247.

3.5 Fledermaus & Qimera
351 .cmap format

To use the .cmap colour map files in the QPS software Fle-
dermaus and Qimera, download the external package from
www.fabiocrameri.ch/colourmaps or via the direct link.

3.6 GIMP/Inkscape
3.6.1 .gpl format

To import the .gpl palettes, launch GIMP and go to Windows >
Dockable Dialogs > Palettes to open the Palettes dialog. Then
right-click anywhere on the list of palettes and select Import
Palette. In the *Import a New Palette* dialog, select the *Palette
file* radio button and then the button just to the right of the
folder icon.

Then, navigate to and select the desired .gpl file in the corre-
sponding folder. Clicking the *Import* button will add the scien-
tific colour map to the existing list of palettes.
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3.7 GMT

3.7.1 .cpt format

3.8 Gnuplot

3.8.1 .pal format

3.9 ImageJ/Fiji

391 .lut format

Note: GMT 6.0.0 and later offers built-in Scientific colour maps
(see Section 4).

The file davos.cpt can be resampled for a given z-value range
with the Generic Mapping Tools (GMT; http://www.generic-
mapping-tools.org) command “makecpt”.

For example to resample for an array from -2000 to 2000 in 100
increments you could generate a new file with:

$makecpt -Cdavos.cpt -T-2000/2000/100 > davos_resampled.cpt

Launch the Gnuplot shell and load the specific .pal file (e.g., bat-
low) into Gnuplot with:

user@computer gnuplot
gnuplot> load "batlow.pal"

The .lut colour-map file (e.g., *batlow.lut*) can be imported to
Imaged or Fiji by placing it in the *luts* folder (to reveal folder
location in Fiji: File > Show Folder > LUTs). Upon restart of Im-
aged, the scientific colour map(s) should then be available under
Image > Lookup Tables.

Alternatively, the colour-map .lut file may be applied using either
(a) File > Open, (b) File > Import > LUT, or (c) drag and drop
the .lut file onto the Imaged window. To view available LUTs:
Image > Color > Display LUTs.

3.9.2 NeuroCyto LUTs add-on

310 Julia

Detailed information about how to use a simple add-on that
adds a handy LUTs drop-down menu to the Fiji user interface
is given on https://forum.image.sc/t/neurocyto-luts-update-
site/26244.

The programming language Julia has built in Scientific colour
maps in its colour map libraries, which makes them readily use-
able. The Julia file containing the colour maps is scicolor. jl:
github.com/JuliaGraphics/ColorSchemes,jl/tree/master/data.
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311 Kingdom
311 clm format

On any screen, select Show color bar from the toolbar. Above
the colour bar that appears, select Select?, then under Files of
type choose Color Bars (*.CLM), then navigate to the location
the colour-map files are stored.

The continuous Scientific colour maps are also provided exter-
nally in Kingdom’s native file format, .clb, for easier implementa-
tion. The clb files are available separately on www.fabiocrameri.ch/
colourmaps. To import them in Kingdom, select, on any screen,
Show color bar from the toolbar. Above the colour bar that ap-
pears, select Select?, then navigate to the location the colour-
map files are stored.

312 Mathematica
3121 .mat format

ColorMapSuitePath = "/Path/To/ColourMapSuite/";

ColorMapSuite [name_String] := ColorMapSuite[name, -1]
ColorMapSuite [name_String, el_] := With[{
list =

Transpose@{Subdivide[0, 1, 255],
RGBColor Q@@
First@Import [
ColorMapSuitePath <> "/" <> name <> "/" <> name <> ".mat"]}

},
Blend[list, {##}[[elll] &
]
The function call ColorMapSuite["name", i = -1] returnsalambda

function whose ith argument is used to define color (see the
Manual for ColorFunction for details). "name" should be replaced
with the name (in quotes) of the color scheme, e.g. "davos". Be
sure to set the variable ColorMapSuitePath to the path where
your ColorMapSuite is installed.

General rules are:

* 1D plots of 1D functions/data: no (default) argument *i* suf-
fices

» 2D plots of 2D functions/data: no (default) argument *i* suf-
fices

* 3D plots of 2D functions/data: use *i* = 3

* 3D plots of 3D functions/data: use *i* = 4 (results might be
worse than default Mathematica color functions, possibly
due to lack of surface normal mapping)

ContourPlot[Sin[x] Sin[y], {x, 0, 2 Pi},
{y, 0, 2 Pi}, ColorFunction -> ColorMapSuite["davos"]]
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313 MatLab
3131 .mat format)

Load the colour map into MatLab, either by adding the .mat file
to the MatlLab search path and using the command:

load('davos.mat');

or by specifying the full file path to the .mat file:
load('~/work/Colormaps/davos.mat');

Then use it, for example, with:

figure(1)
colormap(davos)
colorbar

3.13.2 File-exchange app

A convenient MatLab package provided by Chad Greene con-
taining the full scientific colour-map suite is available on MatlLab
file exchange.

314 Ncview
3141 .ncmap format

The colour map .ncmap files can live in the following places:

1. NCVIEW_LIB_DIR, which is determined at installation time. A
reasonable choice is /usr/local/lib/ncview.

2. Inadirectory named by the environmental variable NCVIEWBASE.
3. If there is no environmental variable NCVIEWBASE, then in $HOME.
4. In the current working directory.

Then when you open Ncview, it should automatically have all of
the colour maps available.

315 OpendTect

For Import to OpendTect follow these steps:

1. Download the OpendTect package by Kaspar Merz from this
direct link or via the separate link on www.fabiocrameri.ch/
colourmaps under the section “Usable with:”

. Click on Survey/Manage/ColorTables. ..

. Click on Import...

. Select file; navigate to directory and open this file

. Select desired colour maps

. Import

OO N NN

3.16 Originlab
3.16.1  .pal format

To use the .pal colour map files in the Originlab software, down-
load the external package from www.fabiocrameri.ch/colourmaps
or via the direct link. The .PAL files can then be copied to the
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317 Paraview

3171 xml format

318 Petrel

3.18.1 .alut format

3.19 Photoshop

3.19.1 .grd format

3.20 Plotly

3.20.1 .py format

origin palette folder and used similarly to the Originlab default
color palettes.

Using Scientific colour maps in Paraview is done via the follow-
ing procedure:

Click Edit color map panel. Once the colour map settings open,

click the folder with the heart (i.e., Choose Preset), then Import,

and then choose the PARAVIEW.xml format (e.g., batlow_PARAVIEW.xml).
The colour map is now loaded and saved in Paraview, so one

can now simply search for the colour map name (e.g., batlow) in

the search field for the colour maps. Click on the desired colour

map and hit Apply.

To import colour maps, select the templates pane and colour
tables folder.

Then select the folder to import into (or insert a new folder) and
right click import on selection.

Select colour tables (alut files) (*.alut) to view and select
all suitable colour maps for import.

Accept default settings trim colour control points and trim
opacity control points and finally use as any other colour table
within Petrel.

The .grd format to read into Photoshop provided by Steven
Reddy can be found at: www.geoscienceatomprobe.org/downloads.html

Plotly versions of the Scientific colour maps are provided by
Emilia are available at https://github.com/empet/scientific-colorscales.

The plotly Scientific colour maps (see the file scicolorscales.py)
were created by converting the provided .py file of each colour
map.

Direct applications and some scientific tests are illustrated in
this Jupyter Notebook: http://nbviewer.jupyter.org/github/empet/
scientific-colorscales/blob/master/Tests-for-scientific-colorscales.ipynb.

10
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3.21 Python
3.21.1 Package (pip and anaconda)

The convenient python package, https://pypi.org/project/cmcrameri/,
by Callum Rollo is available through pip and anaconda.

Install with pip:
pip install cmcrameri

Install with conda:

conda config --add channels conda-forge
conda install cmcrameri

Usage example:

from cmcrameri import cm

import matplotlib.pyplot as plt

import numpy as np

X = np.linspace(0, 100, 100) [None, :]

plt.imshow(x, aspect='auto', cmap=cm.batlow) # or any other colourmap
plt.axis('off')

plt.show()

3.21.2 init file

A simple init file located in ScientificColourMaps6/+TO0LS/ can
be used to make the whole suite of colour maps readily avail-
able in python: Place the __init__.py file in the main directory
ScientificColourMaps7/ and update your PYTHONPATH environ-
ment like this:

(for linux/bash)
export PYTHONPATH=$PYTHONPATH:/full/path/to/ScientificColourMaps7/

Then, in any python, you can import the palette collection, by
using import ScientificColourMaps7 as SCM7, which allows for
example commands like

plt.imshow(some_data, cmap=SCM7.berlin) # Linear palette
plt.imshow(some_data, cmap=SCM7.berlin_r) # Reversed, linear
plt.imshow(some_data, cmap=SCM7.berlin25_r) # Reversed, 25 steps, discrete

3.21.3  .txt format
Step 1: Load colour-map data
Load the colour-map data into Python using numpy.loadtxt():

import numpy as np
cm_data = np.loadtxt("batlow.txt")

Step 2: Set up colour map

Use matplotlib.colors.LinearSegmentedColormap() to create a
colour map that can be used with matplotlib.

from matplotlib.colors import LinearSegmentedColormap
batlow_map = LinearSegmentedColormap.from_list(?batlow?, cm_data)

Scientific Colour Maps 1
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Complete example:

import numpy as np
import matplotlib.pyplot as plt
from matplotlib.colors import LinearSegmentedColormap

cm_data = np.loadtxt("batlow_RGB(0-1).txt")
batlow_map = LinearSegmentedColormap.from_list(?batlow?, cm_data)

x = np.linspace(0, 100, 100) [None, :]
plt.imshow(x, aspect=7auto?,cmap=batlow_map)
plt.axis(70ff?)

plt.show()

3.21.4 palettable library

The palettable library provides the Scientific colour maps (and
other scientifically-derived colour maps) in a convenient way
for use with e.g., matplotlib. Palettable is available on PyPI for
installation via pip: pip install palettable. Palettable is com-
patible with Python 2.6, 2.7, and Python 3. For more instructions
see here.

3.22 QGIS
3.22.1  xml format
Load the colour map into QGIS in:

Settings > Style manager > Import/Export > Import symbol(s)
> select the xxx_QGIS.xml file.

323 R
3.23.1 scico package

‘scico’ (https://travis-ci.org/thomasp85/scico) - pronounced as
“psycho” - is a small package developed by Thomas Lin Peder-
sen that provides access to the Scientific colour maps within R.
It provides colour palettes for ‘ggplot2’) without requiring ‘gg-
plot2’ to be installed.

scico can beinstalled from CRAN with install.packages('scico').
If you want the development version then install directly from
GitHub:

# install.packages("devtools")
devtools::install_github("thomasp85/scico")

For further details and user instructions are included in a README
file within ‘scico’.

3.24 SKUA-GOCAD

3.241 xcmap format

To import a colormap into a SKUA-GOCAD project, navigate to
File > Import > GOCAD Resources > Colormaps.
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3.25 Vislt
3251 .ct format

Alternatively, for advanced users, to include a colormap as a re-
source in all new projects, insert the .xcmap text into the *col-
ormaps.xml* file located in */Gocad/1lib/app-defaults.

The file davos.ct can imported to Vislt by placing the .ct file in
the .visit directory, which can be found on macOS under e.g.,:

/Applications/VisIt.app/Contents/Resources/ ...
. 2.12.3/darwin-x86_64/resources/colortables

The colour map should appear in the built-in list after Vislt has
been restarted.

Scientific Colour Maps
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4 Software with built-in versions

5 References

6 Version history

*+ GMT 6.0 and later

* TopoToolbox 2.2 and later

* StaglLab 3.0 and later

* SubMachine

* Geoscience ANALYST 2.80 and later
* |lgor Pro 9.0 and later

* XMapTools 3.4.2 and later

* KDE LabPlot 2.9 and later

Included colour-map diagnostics are based on:

Kovesi (2015), Good Colour Maps: How to Design Them, CoRR,
abs/1509.03700, http://arxiv.org/abs/1509.03700* and related
MatLab functions available at https://www.peterkovesi.com/
matlabfns/index.html#colour.

For further details see:

Crameri, F. (2018), Geodynamic diagnostics, scientific visual-
isation and StaglLab 3.0, Geosci. Model Dev., 11, 2541-2562,
doi:10.5194/gmd-11-2541-2018

Crameri, F., G.E. Shephard, and P.J. Heron (2020), The misuse
of colour in science communication, Nature Communications, 11,
5444. doi: 10.1038/s41467-020-19160-7

Version 1: Original colour-map suite (bilbao, broc, cork, davos, devon,

grayC, lajolla, oslo, vik)

Version 2 : Additional colour-map file formats (.ct, .py, .svg)

Version 3 : Additional colour-map file format (.txt)

Dark background palettes (berlin, lisbon, tofino)
Additional sequential palettes (lapaz, tokyo, turku)
Surface topography special palette (oleron)

Seismic tomography special palette (roma)

Version 4 : Additional sequential palettes (acton, bamako, buda, hawaii,

imola, nuuk)
Scientific rainbow palette (batlow)

Additional colour-map file formats (xmIQGIS, .clr)

Version 5 : Discrete colour maps (e.g., batlow10)

Improved perceptual uniformity of the original (v1) palettes

Minor colour adjustment to vik

14
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https://docs.generic-mapping-tools.org/latest/cookbook/cpts.html
https://topotoolbox.wordpress.com/2018/08/13/overview-of-scientific-colormaps/
https://www.fabiocrameri.ch/staglab.php
https://www.earth.ox.ac.uk/~smachine/cgi/index.php
http://www.mirageoscience.com/our-products/software-product/geoscience-analyst
https://www.wavemetrics.com/products/igorpro
https://www.xmaptools.com/additional-tools-files/
https://labplot.kde.org/2021/04/29/color-maps-and-conditional-formatting/
https://www.peterkovesi.com/matlabfns/index.html#colour
https://www.peterkovesi.com/matlabfns/index.html#colour
https://doi.org/10.5194/gmd-11-2541-2018
https://doi.org/10.1038/s41467-020-19160-7

Version 6 :

Version 7 :

Additional colour-map file formats (.alut, .ct, .lut, .ncmap,
pal, .spk, .xcmap)

Categorical colour maps (batlowS, devonS, davosS, osloS,
lapaz$S, actonS, lajollas, bilbaoS, grayCs, tokyoS, turkuS, ba-
makoS, nuukS, hawaiiS, budas, imola$S)

Cyclic colour maps (romaO, brocO, corkO, vikO)

Improved colour-map diagnostics for perceptual unifor-
mity

Additional colour-map file formats (.clm)
Improved User guide

Change to MIT License

Additional diverging palettes (bam, vanimo)
Additional cyclic palette (bamO)

Additional multi-sequential palettes (bukavu, fes)
batlowW: batlow with white ending

batlowK: batlow with black ending

cork: Improved lightness symmetry

roma: Improved lightness symmetry

More formats (e.qg., .pal for OriginLab)

Updated __init__.pyto flip colour gradients by Tobias Staal
New Python package by Callum Rollo

Colour map type and class flow chart

Scientific Colour Maps



7 License

The Scientific colour maps are licensed under a MIT License
Copyright (c) 2021, Fabio Crameri

Permission is hereby granted, free of charge, to any person ob-
taining a copy of this software and associated documentation
files (the "Software”), to deal in the Software without restric-
tion, including without limitation the rights to use, copy, modify,
merge, publish, distribute, sublicense, and/or sell copies of the
Software, and to permit persons to whom the Software is fur-
nished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be
included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS”, WITHOUT WARRANTY OF
ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR
ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE
USE OR OTHER DEALINGS IN THE SOFTWARE.

e
Scientific
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https://choosealicense.com/licenses/mit/
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